Honda CBR 500 Riders Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
When on the bike the right side blinker/running light seems to have a power issue. The running light does not work, the blinker however does work when I turn it on to turn. I dont want to get pulled over for a non working light. I checked the connection and it was solid. I see that it is just 1 bulb so I doubt that's what the problem is. I bought the bike 2 weeks ago and didn't notice if it was like this already or just recently happened. If anyone has some insight let me know please, thanks.
 

Attachments

·
Registered
Joined
·
22 Posts
Discussion Starter #5
It's usually the bulb when this happens.
I think it is because I did what @jdock said to do and it did not work. I put them back as they were and now both running lights dont work. I checked the fuse box which I did not find exactly one for Running lights just 1 fuse that says Turn/Odd and that fuse was fine. I will buy a new bulb and see if that fixes the issue.
 

·
Registered
Joined
·
47 Posts
I think the fronts are two way and the rear is signal only. I recall having one front go out and the whole side went wonky. Just go grab some new bulbs at the auto store and pop then in. I'd just replace all of them because when one goes bad the others seem to follow. Hope that works.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
I think the fronts are two way and the rear is signal only. I recall having one front go out and the whole side went wonky. Just go grab some new bulbs at the auto store and pop then in. I'd just replace all of them because when one goes bad the others seem to follow. Hope that works.
Today I went on the longest ride so far about 2.5hours in total. Magically when I got home they both seemed to work just fine. Im thinking this is an electrical issue now.
 

·
Registered
Joined
·
81 Posts
I'm confused.
You swapped side to side and they BOTH didnt work??
Then put back to original position and they both worked??
Take a look inside the bulb socket and look for anything that look like it has been scratched.
Then check the bulb mating surface for anything that looks funny.
Cant believe you have electrical problem on a newer bike.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
I'm confused.
You swapped side to side and they BOTH didnt work??
Then put back to original position and they both worked??
Take a look inside the bulb socket and look for anything that look like it has been scratched.
Then check the bulb mating surface for anything that looks funny.
Cant believe you have electrical problem on a newer bike.
Originally the right one did not work. I switched them and the bulb worked on the left but not the right after the swap so I knew it wasn't the bulb. I switched the bulbs back to its original housing and when I turned the bike on neither worked (which this was fine as it wasn't drawing attention from having only one off) The next day I went on about a 2.5hour ride with a buddy and I noticed when I got back home that both were magically working (this was yesterday). I took her out for a ride today and they both worked, when I got home the left side is not working now... It definitely has to be an electrical issue. But I can seem to understand where the problem is. I thought it might be the wiring on the ride side and now im having issues on the left. I want to buy other bulbs but I also dont want to spend money as im planning to swap them out anyway to flushmounts.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10

·
Registered
Joined
·
81 Posts
Dont change out the existing UNTIL you figure out the problem.
You wont want the new ones to have some mystery problem!

Using a good bulb, install it make sure it lights, and wiggle wires, smack(with your hand) parts of the bike to check where a problem might be.
Also before the bulb gets too hot wiggle the bulb in the socket, and jiggle the socket around a bit.
You can install and remove bulb WITH the power on if that helps.
 

·
Registered
Joined
·
44 Posts
You wont really find something for our exact bike since no one really makes one specific for it, tst does but those suck they completely sink in the hole left form the stock, the ones i got are meant for a cbr600rr they dont fit exact but they do stick out i can actually see them from the front tho barely but they are there, here is what the front looks like. Also i agree with @jdock you gotta figure out what the problem is first and then buy whichever signals you wanna buy.

 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
Dont change out the existing UNTIL you figure out the problem.
You wont want the new ones to have some mystery problem!

Using a good bulb, install it make sure it lights, and wiggle wires, smack(with your hand) parts of the bike to check where a problem might be.
Also before the bulb gets too hot wiggle the bulb in the socket, and jiggle the socket around a bit.
You can install and remove bulb WITH the power on if that helps.
While the issue is occuring would it possibly work to check with a volt meter and see if Im getting any power?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15
Well quick update. I went ahead and purchased both front turn signal lights at Walmart today (they come in a pack of 2) for about $6 after taxes. The old lights still had the running light filament intact but very worn. When I popped an old one off and compared to a new one there was no doubt in my mind that was the issue and as soon as I installed it on the side that wasn't working bam it lights up! I went ahead and replaced both of them. Ive attached pics of what the worn old ones look like. I hope this helps other people out. Thanks for everyone's feedback and input.
 

Attachments

·
Registered
Joined
·
81 Posts
AS a car the rear light will be on and when you apply the brake it will get brighter.
NOT having a "running" / tail light at night is NO GOOD!!!!
 

·
Registered
Joined
·
1 Posts
My cbr500r 2013 came with flush mount front turn signals when I bought it used two months ago.
They run perfect and they look cool on the bike.
Me, I want to replace them back with the OEM ones.
I like having the day running lights so I can be more visible I guess.
If anybody is interested for a swap let me know please.
 
1 - 20 of 21 Posts
Top