Turn Signals Stopped Working - Honda CBR500R Forum : CB500F and CB500X Forums
 9Likes
Reply
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 07-28-2013, 07:58 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Windsor, Ontario, Canada
Posts: 39
Send a message via Skype™ to grandprixgtp_91
Turn Signals Stopped Working

So my bike just rolled 4000km over on the odometer and just as a present it decided to have the turn signals stop working.

I was on my way to work with it waiting at a traffic light with my left turn signal on. they were working fine all morning and never had a problem before. I was just looking around waiting for the light and when it turned green I took off and made the corner, when I went to go cancel the turn signal I noticed that the signal was not on anymore, but I was able to click the switch to cancel it.

So I played around with them and neither the left or right signal would work.

When I arrived at work I shut the bike off and let it sit for a few minutes and then tried them again. This time they worked, but they were flashing very very slow.

When I went to go leave they had completely stopped working again. So I called the dealer and they told me they had not run into this yet and to bring it in. so I dropped it off on Saturday and they will look at it throughout the week.

I don't think its the switch because when I turn the signals on the front bulb running light shuts off. so it appears to be getting the command for signals.

Probably just a flasher , I would have looked into it myself but being under warranty ill let the dealer take care of it.

This scares me, the bike is only 2 1/2 months old and already has an electrical issue, I asked them if the extended warranty would cover things like this and they were unsure. The brochure said it covers meters and wire harnesses . I think ill be buying the 5 year extended warranty. With this being the first model year for the bike its bound to have odd issues and I don't want to be stuck with a lemon. To many electrical things to go wrong. and for $760 for 5 years unlimited mileage it seems like good peace of mind.

Just thought id let you guys know of this problem so you can keep an eye out on yours. Ill let you know what was wrong when I find out.


Jake


2013 Honda CBR500R In Red And Black
grandprixgtp_91 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-28-2013, 08:06 AM
Super Moderator
 
Mikethebear's Avatar
 
Join Date: Apr 2013
Location: Brisbane, Australia
Posts: 1,174
Garage
Take it to the dealer.
bambams likes this.
Mikethebear is offline  
post #3 of 14 (permalink) Old 07-28-2013, 08:10 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Windsor, Ontario, Canada
Posts: 39
Send a message via Skype™ to grandprixgtp_91
I did....
bambams likes this.

Jake


2013 Honda CBR500R In Red And Black
grandprixgtp_91 is offline  
 
post #4 of 14 (permalink) Old 07-28-2013, 08:52 AM
Super Moderator
 
Mikethebear's Avatar
 
Join Date: Apr 2013
Location: Brisbane, Australia
Posts: 1,174
Garage
How did I miss that whole sentence?
You've won this battle.
bambams likes this.
Mikethebear is offline  
post #5 of 14 (permalink) Old 07-28-2013, 10:15 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Windsor, Ontario, Canada
Posts: 39
Send a message via Skype™ to grandprixgtp_91
Hahaha, its all good.

Jake


2013 Honda CBR500R In Red And Black
grandprixgtp_91 is offline  
post #6 of 14 (permalink) Old 07-28-2013, 10:43 AM
Senior Member
 
BourbonNcigars's Avatar
 
Join Date: Jul 2013
Location: Southern U.S.
Posts: 958
Sorry you can't turn any more. Hey...going straight isn't that bad.

The turn signals pis me off on this thing, anyway. Too hard to reach. It needs to be where the horn is. I hate turning left because it feels like I have to take a good part of my hand off the handlebar to hit the signal.
bambams likes this.
BourbonNcigars is offline  
post #7 of 14 (permalink) Old 07-28-2013, 10:44 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Windsor, Ontario, Canada
Posts: 39
Send a message via Skype™ to grandprixgtp_91
I agree, I do not like where the signal switch is, ive accidently hit the horn twice and drivers think im honking at them lol.

But signals are important on a bike, I don't wanna get hit :s

Jake


2013 Honda CBR500R In Red And Black
grandprixgtp_91 is offline  
post #8 of 14 (permalink) Old 07-28-2013, 10:57 AM
Senior Member
 
Darrenbie's Avatar
 
Join Date: Jun 2013
Location: Florida
Posts: 334
My signals had stopped working but also my display didnt work. It was a fuse that got damaged while I was changing the signals in the front to some flush mounts.

If your display was working then is something completely different.

Good luck

Ride Safe....
Darrenbie is offline  
post #9 of 14 (permalink) Old 07-28-2013, 11:09 AM Thread Starter
Member
 
Join Date: Apr 2013
Location: Windsor, Ontario, Canada
Posts: 39
Send a message via Skype™ to grandprixgtp_91
Ya this isn't a fuse because they were intermittently working and slowly. so that's why Im thinking a flasher, if the flasher is electronic in the display then it could be a bad display. Im curious to see what they find, hopefully they wont have it for more than this week.

Jake


2013 Honda CBR500R In Red And Black
grandprixgtp_91 is offline  
post #10 of 14 (permalink) Old 07-28-2013, 11:30 AM
Senior Member
 
ceebs500's Avatar
 
Join Date: Feb 2013
Location: UK
Posts: 643
Sounds like an earthing problem to me. I think someone here had issues with electrics and it turned out to be the master earth point was loose.

2013 CB500X Pearl White
1955 Triumph Tiger 100
1968 BSA B40 Ex WD
1962 BSA C15 Trials

1970 Austin-Healey Sprite
ceebs500 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda CBR500R Forum : CB500F and CB500X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome